0899641919 Geraldton, WA
Free delivery on orders over $99 Same-day dispatch before 2pm AWST 25+ years trusted service Proudly WA family owned Free delivery on orders over $99 Same-day dispatch before 2pm AWST 25+ years trusted service Proudly WA family owned
Back to Savvy
Htek

HTEK UC912E STANDARD BUSINESS IP PHONE

SKU: IPH-UC912E
$149.00
inc. GST
No Stock
Order now to secure stock from our supplier.
Secure
Payment
Fast
Shipping
Easy
Returns
Authentic
Stock

Product Overview

Phone Features
Up to 4 SIP accounts
Call hold, mute, DND
One-touch speed dial, hotline
Call forward, call waiting, call transfer
Redial, call return, auto answer, direct IP call
5-way conference
Group listening, SMS, emergency call
Ring tone selection/provisioning
Set date time automatically or manually
Dial plan per account
RTCP-XR (RFC3611), VQ-RTCPXR (RFC6035)
Action URL/URI
Voice Codecs Features
HD voice, HD handset, HD speaker
Codecs: iLBC, G.722, G.711(A/μ), Opus
GSM_FR, G.723, G.729AB, G.726-32
DTMF: In-band, RFC 2833, SIP INFO
Full-duplex hands-free speakerphone with AEC
VAD, AGC, CNG, AEC, PLC, AJB
Directory
Local phonebook up to 1000 entries
XML/LDAP remote phonebook
Intelligent search method
Phonebook search/import/export
Call history: dialed/received/missed/forwarded
Black list
IP-PBX Features
Busy Lamp Field (BLF), bridged Line Appearance(BLA)
Anonymous call, anonymous call rejection
Message Waiting Indicator (MWI) , voice mail
Call park, call pickup
Intercom, paging
Music on hold
Hot-desking
Display and Indicator
192x64 pixel graphical LCD with backlight
LED for call and message waiting indication
Illuminated LEDs for line status information
Intuitive user interface with icons and soft keys
National language selection
Caller ID with name, number
Feature keys
4 line keys with LED
4 line keys can be programmed up to
12 various features (4-page view)
Speaker key/headset key/mute key
4 context-sensitive “soft' keys
6 navigation keys, volume control keys
Speaker key/headset key/mute key 6 features keys: voice mail, headset, mute,speaker, transfer, redial
Interface
Dual-port Gigabit Ethernet
Power over Ethernet (IEEE 802.3af), class 2
1xRJ9 (4P4C) handset port
1xRJ9 (4P4C) headset port
Physical Features
Stand with 2 adjustable angles
Wall mountable
External universal AC adapter : AC 100~240V input and DC 5V/1.2A output
Power consumption (PSU): 1.8~4.4W
Power consumption (PoE):

Specifications

category_map_id 1929
price_exc 135.45
lead_note Unavailable
source_updated_at_snapshot 2026-09-25T09:14:05.637828
Brand
Htek
SKU
IPH-UC912E
Category
Technology
Supplier
leasys
EXCLUSIVE REWARDS

Join WorksPerks

Your exclusive rewards program for smarter shopping

Earn Points

1 point per $1 spent

Exclusive Deals

Member-only offers

Free Shipping

On qualifying orders

Tier Rewards

Unlock more benefits

Choose Your Account Type

Complete Your Profile

Minimum 8 characters

Welcome to WorksPerks!

Your account has been created successfully.

+500 Welcome Points